
Welcome to PCoIP Software Client for macOS

Welcome to the Teradici PCoIP® Software Client for macOS Administrators' Guide.

PCoIP Software Clients are applications that establish PCoIP sessions with remote Windows or

Linux desktops. Connections can be made to virtual machines via PCoIP agents, and to remote

workstations via PCoIP Host Software and Remote Workstation Cards.

This guide explains how to install, configure, and use the PCoIP Software Client for macOS. It

includes client system requirements and information on host dependencies.

Welcome to PCoIP Software Client for macOS
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Who Should Read This Guide?

This guide is intended for administrators and users who install, configure, or use the Teradici

PCoIP® Software Client for macOS.

Understanding terms and conventions in Teradici guides

For more information on the industry specific terms, abbreviations, text converntions, and graphic symbols used in

this guide, see Using Teradici Product and Component Guides and the Teradici Glossary.



Who Should Read This Guide?
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What's New in This Release

The PCoIP Software Client for macOS 19.11 introduces the following features and enhancements:

Improved Audio Input Bandwidth

PCoIP monitors the bandwidth available for audio and selects the audio compression algorithm

that provides the best quality possible for the available bandwidth. Previously PCoIP endpoints use

the Opus audio codec for audio output only, now this codec is available for audio input. By using

the OPUS codec for audio input, high quality audio recording is possible even when bandwidth is

limited.

Enhanced Security and Stability

This release contains improvements and enhancements around the security and stability of the

Software Client for Mac.

PCoIP Ultra

This release contains improved support for PCoIP Ultra, our latest PCoIP protocol enhancements.

This is an evolving feature that will continually improve with each release. For more information

see the PCoIP Agent documentation.

Auto-Forward USB Devices

This release enables USB devices to be automatically redirected to the remote desktop on

connection. Either all devices can be forwarded or a set of devices specified by VID/PID.

What's New in This Release
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Additional Documentation

The following guides contain additional information relevant to PCoIP systems and PCoIP

Software Clients:

• For more information about Teradici Cloud Access Software, including detailed information on

included PCoIP components as well as Teradici All Access plans, see the Teradici Cloud

Access Architecture Guide.

• For more information about Teradici PCoIP agents, which are required on remote virtual

machines, see the following pages:

• Teradici PCoIP Standard Agent for Windows

• Teradici PCoIP Graphics Agent for Windows

• Teradici PCoIP Standard Agent for Linux

• Teradici PCoIP Graphics Agent for Linux

• For information about Teradici PCoIP Host Software, which is required on remote

workstations using a Teradici PCoIP Remote Workstation Card, see the following pages:

• PCoIP Host Software for Windows

• PCoIP Host Software for Linux

Additional Documentation
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System Requirements

The following table outlines the system requirements for the PCoIP Software Client for macOS:

System Version Required

PCoIP Software Client Operating Systems
• macOS Catalina (10.15)

• macOS Mojave (10.14)

Compatible PCoIP agents All PCoIP agents and versions

Compatible Teradici Remote Workstation Cards TERA22x0 with firmware 5.0.1+

Compatible PCoIP Host Software
• Host Software for Windows: 4.3.1+

• Host Software for Linux: 4.7.0+

Remote Workstation Platforms

PCoIP Host Software must be installed on Remote Workstation machines to enable keyboard and mouse

functionality.



System Requirements
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Audio Support

Stereo audio output and mono audio input are supported and enabled by default.

Audio Support
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Displays

The PCoIP Client supports a maximum of four displays and a maximum resolution of 4K UHD

(3840×2160).

Monitors can be arranged in a vertical line, a horizontal line, or as a 2×2 box display. They can be

used in any standard rotation (0°, 90°, 180°, or 270°), with any monitor as the primary display.

Note: Using multiple high-resolution displays

Systems with multiple high-resolution displays, such as quad 4K UHD topologies, require powerful system

infrastructure. Be sure to use a system with sufficient bandwidth and client capability to support your required display

topology.



Important: Attaching monitors to the host machine in not supported

PCoIP client supports a maximum of four displays. Attaching extra monitors to the host machine will conflict with

client display topologies.



Displays
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Supported Languages

The PCoIP Client supports the following languages:

• French

• German

• Spanish

• Simplified Chinese

• Traditional Chinese

• Japanese

• Portuguese

• Italian

• Korean 

• Russian

• Turkish

Supported Languages
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PCoIP Ultra

The PCoIP Client provides support for PCoIP Ultra, the latest protocol enhancements from

Teradici. PCoIP Ultra is optimized for truly lossless support with bit-exact color accuracy and

preservation of content detail at the highest frame rates.

PCoIP Ultra protocol enhancements propels our industry-recognized performance into the future

of remote computing, with faster, more interactive experience for users of remote workstations

working with high-resolution content.

PCoIP Ultra enhancements are controlled on the PCoIP Agent. There is no configuration required

on the PCoIP Client.

When to Enable PCoIP Ultra

In release 19.11, PCoIP Ultra supports the following use cases:

• Users requiring CPU-optimized delivery of 4K UHD, high-framerate video playback.

• Efficient scaling across multicore CPUs, leveraging AVX2 instruction sets.

For all other scenarios, Teradici recommends that you leave PCoIP Ultra disabled.

Requirements

To take advantage of PCoIP Ultra, you need:

• A PCoIP Agent (any type), 2.15 or later

• A PCoIP Software Client (any type), 2.15 or later

• The CPUs on both the agent and the client machines must support the AVX2 instruction set.

PCoIP Ultra is appropriate for specific use cases

For most users, the default PCoIP protocol will provide the best possible experience. Carefully review the

recommended use cases in the next section to determine whether you should enable it.



PCoIP Ultra
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Enabling PCoIP Ultra

In order to enable PCoIP Ultra features you need to turn on GPO variables. For information on this,

see Enabling PCoIP Ultra. 

Enabling PCoIP Ultra
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Printing Support

When a local printer is visible to a client computer by USB connection or local network connection,

it may be possible to print from the host machine. Refer to the following table for local printing

support.

Cloud printing is available from all clients if supported by the desktop system and correct PCoIP

Agent.

The PCoIP Standard Agent for Linux does not support local printing on remote clients.

Local, network, and cloud printers are supported in various ways:

• Linux hosts can print to any printer on the host machine’s local area network.

• If your host host workstation has access to the Internet, cloud-based printing is supported

through cloud-printing services such as Google Cloud Print and HP Mobile Printing.

PCoIP Agent for Windows PCoIP Agent for Linux

Local USB Printing  

printer is connected to a USB port on the client computer

—

Local Network Printing  —

Cloud Printing  —

Printing Support
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USB Support

PCoIP Clients supports redirecting USB devices to a remote session. Administrators can set rules

governing allowed and disallowed devices, device classes, or device protocols. 

Isochronous USB device support

USB devices with time-sensitive information, such as webcams, are not generally supported.

However, Teradici's technology partners provide additional solutions to expand peripheral support

such as webcams. For more information, look for partners listed under Peripherals on the Teradici

Technology Partners page.

Important: USB support is enabled by default

USB bridging is enabled by default. If you want to restrict or disable USB support, you can globally disable or set rules

governing USB behavior via GPO settings on the PCoIP Agent.



USB Support
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Wacom Tablet Support

The Software Client for Mac supports Wacom tablets in a bridged configuration, where peripheral

data is sent to the desktop for processing.

Bridged Wacom Tablets

Bridged Wacom tablets are supported only in low-latency environments. Tablets in network

environments with greater than 25ms latency will show reduced responsiveness and are not

recommended.

The following Wacom tablet models have been tested and are supported on a PCoIP Software

Client for Mac.

PCoIP client support for bridged Wacom tablets and the Software Client for Mac

Other Wacom tablets may work, but have not been tested.

PTK-440 PTH-451 PTH-660 PTH-860 Cintiq 22HD

PCoIP Standard Agent for Linux  —   —

PCoIP Graphics Agent for Linux  —   —

PCoIP Standard Agent for Windows  —   —

PCoIP Graphics Agent for Windows  —   —

PCoIP Remote Workstation Card — — — — —

Wacom Tablet Support
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Installing the PCoIP Software Client for macOS

In this section, you'll learn how to install and uninstall the PCoIP Software Client for macOS.

Before You Begin

Before installing a PCoIP Software Client:

• You must be logged in as an administrator to the client machine.

• Close any existing PCoIP Software Client applications.

Installing the PCoIP Software Client

To install the PCoIP Software Client:

1. Copy the PCoIP Software Client disk image file PCoIPClient.dmg to your desktop.

2. Double-click the file to mount the volume.

3. Accept the license agreement by clicking Agree.

4. In the PCoIPClient volume window, drag the PCoIPClient icon into the Applications folder icon

to install the program.

5. To optionally create an alias on the desktop or the dock:

• Double-click the Applications folder icon to open the folder.

Installing the PCoIP Software Client for macOS
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• Drag the client application to the desktop or dock.

6. To eject the volume when you are finished, drag it to the trash.

To uninstall the PCoIP Software Client:

• Navigate to the Applications folder and drag the PCoIPClient program to the trash. Or, right-

click the application and select Move to Trash.

To uninstall the PCoIP Software Client:
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Using the PCoIP Software Client

After installing a PCoIP Software Client on your client machine, you can connect to the following

PCoIP solutions or products or hosts:

• Teradici PCoIP Graphics Agent or PCoIP Standard Agent installed as part of Teradici Cloud

Access Software.

• Teradici PCoIP Remote Workstation Card and Teradici PCoIP Host Software installed in a

Windows or Linux workstation.

Using the PCoIP Software Client
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Connecting to Virtual Machines

You can connect to virtual Windows or Linux hosts that have a PCoIP Standard Agent or PCoIP

Graphics Agent installed. Connections can be made directly to individual host machines, or via a

connection broker in managed deployments.

To connect to a remote workstation or virtual desktop:

1. Double-click the PCoIP Client desktop icon, alias, or program file PCoIPClient to launch the

application.

2. In the Host Address or Code field, enter one of the following:

• For direct connections, provide the address of the host machine.

• For managed connections, provide the address of the connection manager. 

If you want to save this connection later for easy recall, enter a name in the Connection Name

field. You will save the connection in step 5.

3. Click NEXT.

Connecting to Virtual Machines
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4. On the next screen, select your domain from the dropdown list, enter your user name and

password for the desktop, and then click LOGIN. 

If your domain does not appear in the list, specify it along with your user name (for example, 

).MyDomain\MyUserName

About the Security Padlock Indicator

The login screen displays a red padlock indicator when accessing a PCoIP agent desktop that uses default self-

signed certificates. The icon indicates that the software’s certificate is not signed by a trusted certificate

authority (CA). You can use your own CA to create a certificate and then install the appropriate files at each end.

If the client trusts your internal CA, a green padlock icon displays on the screen instead. To learn more about

certificates, see the PCoIP agent administrators guides listed in the Teradici Cloud Access Architecture Guide.



To connect to a remote workstation or virtual desktop:
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5. If your login is successful, the following screen appears with a list of available desktops: 

6. Click Connect to connect to the selected desktop.

A short interface delay is normal

When a session is first connected, it may take a few seconds before you can take control of the keyboard and mouse.

This is normal behavior.



To connect to a remote workstation or virtual desktop:
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Connecting to Amazon Workspaces

You can connect to Amazon Workspaces desktops for either Linux or Windows. Connections can

use either Active Directory or an existing Radius server to provide multi-factor authentication

(MFA).

To connect to a virtual desktop:

1. Double-click the PCoIP Client desktop icon, alias, or program file PCoIPClient to launch the

application.

2. In the Host Address or Code field, enter the Amazon Workspaces registration code: 

If you want to save this connection later for easy recall, enter a name in the Connection Name

field.

3. Click NEXT.

Connecting to Amazon Workspaces
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4. On the next screen, enter your Amazon Workspaces Username, Password and MFA token and

then click OK. 

About the Security Padlock Indicator

The login screen displays a red padlock indicator when accessing a PCoIP agent desktop that uses default self-

signed certificates. The icon indicates that the software’s certificate is not signed by a trusted certificate

authority (CA). You can use your own CA to create a certificate and then install the appropriate files at each end.

If the client trusts your internal CA, a green padlock icon displays on the screen instead. For information on

security features around certificates, see PCoIP Software Client Security Modes. To learn more about

certificates, see the PCoIP agent administrators guides listed in the Teradici Cloud Access Architecture Guide.



A short interface delay is normal

When a session is first connected, it may take a few seconds before you can take control of the keyboard and mouse.

This is normal behavior.



To connect to a virtual desktop:

© 2019 Teradici 21

http://www.teradici.com/web-help/pcoip_cloud_access_arch/current/


Connecting to Teradici PCoIP Remote Workstation
Cards

You can connect to remote workstations with a Teradici PCoIP Remote Workstation Card and

PCoIP Host Software installed. Refer to System Requirements for supported versions.

Initial Workstation Configuration

Before you can connect to your remote workstation for the first time, a few things must be

configured on the host machine.

These configuration actions only need to be taken once on each remote workstation in your

system:

• Enable monitor emulation for the video ports on your remote workstation

If monitor emulation is not enabled, you may see blank gray screens when you connect from

the PCoIP Software Client.

To enable monitor emulation, log in to the card’s Administrator Web Interface (AWI) and select

Enable Monitor Emulation on Video Port n from the Configuration > Monitor Emulation menu.

For more information, see the Tera2 PCoIP Zero Client Firmware 4.x and Remote Workstation

Card Firmware 4.9 Administrators' Guide.

• Disable temporal dithering

Temporal dithering causes blurriness, heavy packet loss, and high CPU usage on the PCoIP

Software Client machine. See Should I disable the dithering feature of my graphics card in a

remote workstation environment? (KB 15134-207) for more information.

• Linux workstations: configure PCoIP Host Software to Start Automatically

To configure the PCoIP host software to start automatically, log into the workstation using a

PCoIP Zero Client or directly from a local mouse and keyboard, and modify the workstation

startup script to launch the PCoIP host software. For details, see Installing PCoIP Host

Software Binary RPM in the PCoIP® Host Software for Linux User Guide.

Connecting to Teradici PCoIP Remote Workstation Cards

© 2019 Teradici 22

http://www.teradici.com/web-help/pcoip_zero_client/tera2/6.0.0/
http://www.teradici.com/web-help/pcoip_zero_client/tera2/6.0.0/
http://www.teradici.com/web-help/pcoip_host_software/linux/4.7.0/TER1104006_Issue_7_PCoIP_Host_Software_for_Linux_User_Guide%20(1).pdf


Connecting to a Remote Workstation Card

Once the remote workstation is properly configured, you can connect to it from the PCoIP

Software Client.

To connect to a remote workstation with a Teradici PCoIP Remote Workstation

Card installed:

1. Double-click the PCoIP Client desktop icon, alias, or program file (PCoIPClient) to launch the

application.

2. In the Host Address box, enter the fully-qualified computer name or IP address of the Teradici

PCoIP Remote Workstation Card installed in the remote workstation.

3. Optional: In the Connection Name box, enter a name for your connection. This field accepts

any Unicode character.

4. Click NEXT.

Workstation configuration is required before connecting

If you experience connection problems or degraded performance, make sure that the workstation is configured as

described in Initial Workstation Configuration.



The Connection Information can be saved

If you provide a connection name now, you will have the option of saving the connection after you are

authenticated. Saved connections can be quickly recalled later, without manually re-entering connection

information.



Connecting to a Remote Workstation Card
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5. If your desktop is locked upon connection and requires you to enter Ctrl+Alt+Delete to log in,

select Connection > Send CTRL-ALT-DEL from the PCoIP Software Client menu bar.

A short interface delay is normal

When a session is first connected, it may take a few seconds before you can take control of the keyboard and

mouse. This is normal behavior.



To connect to a remote workstation with a Teradici PCoIP Remote Workstation Card installed:
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Connecting to a USB Device

Remote Windows hosts using the PCoIP Standard Agent or the PCoIP Graphics Agent can use

USB devices that are attached to the client. When you connect a local USB device to your remote

host it will be disabled on the client machine.

USB device connections do not persist across multiple PCoIP sessions. You must connect your

USB device each time you connect.

USB Auto-Forward

Automatic bridging enables you to auto bridge all non-HID USB devices. Use the 

 command line parameter.

USB Vendor ID/Product ID Auto-Forward

You can automatically forward up to 20 USB devices to the host at the start of the session by

calling the PCoIP client executable with  and the required VID/PID pairs.

Devices that are auto-forwarded will appear in the USB Devices dialog box, enabling users to

connect or disconnect them from the host. The following rules apply to VID and PID values:

• VID/PID values are comma-separated: ,

• VID/PID pairs are space-separated:  

PCoIP Agent needs to be configured to enable USB redirection

The USB menu will only show up if the PCoIP Agent has been configured to enable USB redirection and a USB device

has been detected by the PCoIP Client.



One-time PCoIP Software Client for macOS login

The first time you connect after a Mac installation, you must enter a Mac administrator user name and password. You

only need to do this when you install a new client.



usb-auto-

forward

vidpid-auto-forward

xxx yyy

aaa, bbb ccc,ddd

Connecting to a USB Device
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• VID/PID pairs with invalid values will be discarded. Discarded rules appear in the event log.

• Up to 20 devices will be passed; if more than 20 are attempted, the first 20 will be accepted

and rest ignored. Ignored rules appear in the event log.

To connect to a USB device:

1. Attach the USB device you want to connect.

2. Select Connection > USB Devices from the PCoIP Software Client menu.

A list of USB devices connected to your client machine appears. Integrated USB devices, such

as built-in cameras on laptops, will appear in this list along with devices you have plugged in

yourself.

Some devices will identify themselves only as USB Device.

3. Click Connect beside the USB device you want to use. 

To connect to a USB device:
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To disconnect a USB device:

1. Select Connection > USB Devices from the PCoIP Software Client menu.

2. Click Disconnect beside the USB device you want to disconnect. 

Connecting to Human Interface Devices

Most Human Interface Devices (HIDs), such as keyboards and mice, are automatically handled by the PCoIP Software

Client and don't appear on in this list even if they use a USB connection.

If you need to connect a Human Interface Device that can't be locally processed, like a 3D mouse or a Wacom tablet,

enable the Show Human Interface Devices checkbox to reveal the device in the USB device list and click its Connect

button.

You may also have to complete additional configuration steps or install drivers on the host machine.



To disconnect a USB device:
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Using Saved Connections

Once you have saved a connection, you can use it to reconnect easily.

To reconnect using your saved connection:

1. Click the button for the saved connection. The button label displays the connection name you

assigned when you configured the connection. 

2. To see the connection address, hover your mouse over the saved connection. Hovering over a

saved virtual desktop will also show the desktop name. 

Using Saved Connections
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3. To edit or delete a saved connection, click the configure button on the right, and then select

the desired option from the popup menu. 

4. If you have saved multiple connections, click the desired one to reconnect. If you have more

than four saved connections, additional saved connection buttons appear in an extended area

of the page. Use the forward and back arrows to navigate between areas. 

5. Any time you wish to connect to a new workstation, just click NEW CONNECTION to return to

the main screen, and then enter the connection details.

To reconnect using your saved connection:
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Disconnecting a Session

To disconnect a PCoIP session from either client, select the Connection > Disconnect menu

option.

Quitting the application will also disconnect the current session.

Session Reconnection

If a network interruption is detected, the PCoIP session enters a reconnecting phase. In this phase

the client will show you the network reconnecting dialog which indicates that there is a network

issue and that the client is trying to reconnect and re-establish the PCoIP session. You can click 

disconnect to cancel the attempted reconnect and disconnect the session completely. If the

reconnection is successful, the notification dialog will disappear and the session will be restored, if

not, the session will be disconnected completely.

Quickly Disconnect from a session

To quickly disconnect from a session, press CTRL+Option+F12



Disconnecting a Session
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Changing the PCoIP Software Client Window Mode

You can use the PCoIP Software Client in full-screen or windowed mode. Full-screen mode is

recommended in most cases.

Activating Full Screen Modes

The PCoIP Software Client provides two full-screen modes: one monitor and all monitors.

To switch from windowed mode to full-screen mode:

• To use one full-screen display, select View > Show Fullscreen One Monitor.

All open windows and applications will be moved to a single full-screen display. This is

equivalent to disconnecting all but one monitor from a physical host.

• To use all available full-screen displays, select View > Show Fullscreen All Monitors.

This mode shows full-screen displays on all client monitors.

To switch from Fullscreen One Monitor to Fullscreen All Monitors mode:

1. Reveal the menu bar by moving the mouse cursor to the top of a client display.

2. Select View > Show Fullscreen All Monitors.

To switch from Fullscreen All Monitors to Fullscreen One Monitor mode:

1. Reveal the menu bar by moving the mouse cursor to the top of a client display.

2. Select View > Show Fullscreen One Monitor.

Keyboard shortcut

You can also enter full-screen mode by pressing Ctrl+Option+Return while in windowed mode. The shortcut will

activate whichever full-screen mode was used last, or all monitors if no previous selection was made.



Changing the PCoIP Software Client Window Mode
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Miminizing the PCoIP Software Client from a Full-screen Mode

To minimize a software client in full-screen mode:

1. Reveal the menu bar by moving the mouse cursor to the top of any display.

2. Select View > Minimize Client.

Activating Windowed Mode

To switch from full-screen mode to windowed mode:

1. Reveal the menu bar by moving the mouse cursor to the top of any display.

2. Select View > Leave Fullscreen.

Persistent Display Topology

Depending on the display topology mode you have selected, for example Fullscreen One Monitor, if you disconnect

and then reconnect to the session, it will maintain that same mode upon reconnection. The state and mode will be

preserved.



Keyboard shortcut

You can also minimize the client by pressing Ctrl+Option+m while in any full-screen mode.



Keyboard shortcut

You can also enter windowed mode by pressing Ctrl+Option+Return while in any full-screen mode.



Miminizing the PCoIP Software Client from a Full-screen Mode
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Enhanced Audio and Video Synchronization

Enhanced Audio and Video Synchronization provides improved full-screen video playback,

reducing the difference in delays between the audio and video channels and smoothing frame

playback on the client. This improves lip sync and reduces video frame drops for movie playback.

This feature introduces a small lag in user interaction responsiveness when enabled. Using

enhanced audio and video synchronization will reduce the maximum frame rate.

Enhanced A/V Sync is enabled on a per-display basis, so you can dedicate individual displays to

playback without impacting responsiveness on the others.

The enhanced A/V Sync feature is turned off by default and needs to be turned on for the menu

items to appear.

To turn on A/V Sync:

1. Execute the following command: 

The above text is OS specific. Note the setting changed from 0 to 1.

When enabled, a check mark will appear beside the enhanced A/V Sync menu item on that display.

It is disabled on all displays by default.

To use enhanced A/V Sync:

1. If you are in full-screen mode, reveal the menu bar on the display you want to enhance by

moving the mouse cursor to the top of the screen.

2. On the display you want to enhance select View>Enhanced A/V Sync to toggle the enhanced

sync mode.

sudo defaults write "com.teradici.Teradici PCoIP Client.plist" 
enable_enhanced_avsync 1

Enhanced Audio and Video Synchronization
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Persistent Display Topology

The Enhanced Audio and Video Synchronization feature is persistent across sessions from the same client, provided

that the display topology has not changed.



Enhanced Audio and Video Synchronization
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Sending a Ctrl-Alt-Del Command

To send the Ctrl-Alt-Del keyboard command to a remote workstation, select the Connection >

Send CTRL-ALT-DEL menu option.

Sending a Ctrl-Alt-Del Command
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Changing the Language

In addition to English, the PCoIP Software Client also supports these languages: Chinese

(Simplified), French, German, Italian, Japanese, Korean, Portuguese (Brazil), Portuguese (Europe),

Russian, Spanish, and Turkish. During installation, you can select one of the supported languages.

To change the language after installation:

• In System Preferences > Language & Region > Advanced > General tab, select another

language in the Format language list.

Changing the Language
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PCoIP Software Client Security Modes

The PCoIP Software Client uses certificates to verify the identity of the host to which it connects.

The security mode is configured by the  setting in the Teradici PCoIP Client

configuration file, which is described next. Three security mode options are available:

• security_mode=0: verification is not required A red, unlocked padlock icon appears on the

client login screen.

• security_mode=1: warn but allow (default) If a certificate cannot be verified, an 'untrusted

server' warning displays and a red, unlocked padlock icon appears on the client login screen.

Users still have the option of connecting.

This mode is used if  is not set in the configuration file.

• security_mode=2: full verification is required Users cannot connect unless a certificate can be

verified.

Setting the Security Mode

Use the following procedure to set the PCoIP Software Client's security mode.

To set the security mode for the PCoIP Software Client:

1. Close the PCoIP Software Client.

2. Open a terminal window and type the following command at the command line:

where is your desired security option (0, 1, or 2).

security_mode

security_mode

PCoIP sessions are always encrypted

Your PCoIP session is still encrypted and secure if you connect with security mode 0 or 1. The red padlock icon

indicates that the certificate presented by the host is not signed by a trusted certificate authority in the client’s

certificate store, not that the session is insecure.



sudo defaults write "com.teradici.Teradici PCoIP Client.plist" security_mode 

<value>

value

PCoIP Software Client Security Modes
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Reboot May Be Required

After running the above command, you may be required to reboot your machine for this change to take effect.



Setting the Security Mode
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Installing the Internal Root CA Certificate in a PCoIP
Client

Your root CA certificate must be installed in any PCoIP client that will be used to connect to the

PCoIP Agent.

Installing Root CA Certificates in the PCoIP Software Client for macOS

In macOS, certificates are stored in the Keychain Access application.

To import your root CA certificate in the PCoIP Software Client for macOS:

1. Copy your root CA certificate file (*.crt) to the Mac client desktop.

2. Double-click Applications > Utilities Keychain Access.app to open Keychain Access.

3. Select File > Import Items.

4. Navigate to the desktop and then select your root CA certificate.

5. In the Destination Keychain drop-down menu, select System, and then click Open.

6. If prompted, enter your Keychain Access password and then click Modify Keychain.

7. At the next screen, click Always Trust when asked whether you want your computer to trust

certificates signed by this certificate.

8. If prompted, enter your Keychain Access password and then click Update Settings.

After the certificate installs successfully, it appears in the System > Certificates list.

Important: Root CA Certificate must have a .crt extension

You must change the root CA certificate's extension from .pem to .crt before installing it on a PCoIP Software

Client.



Installing the Internal Root CA Certificate in a PCoIP Client
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Contacting Support

If you encounter problems installing or using Teradici technology, you can:

• Check for updated release notes, which may address the issue you are experiencing. Release

notes are published on Teradici Support.

• Browse the Teradici Knowledge Base.

• Submit a support ticket.

Contacting Support
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The Teradici Community Forum

The PCoIP Community Forum allows users to have conversations with other IT professionals to

learn how they resolved issues, find answers to common questions, have peer group discussions

on various topics, and access the Teradici PCoIP Technical Support Service team. Teradici staff

are heavily involved in the forums.

To join the Teradici community, visit the Teradici Community Forum.

The Teradici Community Forum
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Creating a Technical Support File

Teradici may request a support file from your system in order to troubleshoot and diagnose PCoIP

issues.

The support file is a tar.gz archive containing PCoIP Software Client for macOS logs and other

diagnostic data that can help support diagnose your problem.

To create a support file:

1. Open a terminal window.

2. Launch the support bundler:

The file will be created and placed in the user's home directory.

username$ /Applications/PCoIPClient.app/Contents/Resources/pcoip-client-support-

bundler

Creating a Technical Support File
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Checking the PCoIP Software Client Software
Release

The PCoIP Software Client pre-session window contains an About button in the lower left of the

window. Click this button and then select About from the popup menu to display the PCoIP

Software Client software release version.

From either client, you can also select the Teradici PCoIP Client > About Teradici PCoIP Client

menu to display the software release version from within a PCoIP session.

Checking the PCoIP Software Client Software Release
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About menu item only appears when the client is in session

The About Teradici PCoIP Client menu item only appears when the client is in session. The menu item is not available

from the pre-session GUI.



Checking the PCoIP Software Client Software Release
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Troubleshooting Your PCoIP Software Client

This section demonstrates using PCoIP Software Client log files to troubleshoot problems you

may encounter with your PCoIP Software Client.

PCoIP Software Client logs are text (.txt) files that contain system and session information about

your connection. They are useful for troubleshooting problems. A new log file is created each time

you use a PCoIP Software Client to initiate a PCoIP session.

Client logs are placed in .

If you experience a problem, recreate the issue, generate a support bundle and contact Teradici

Support. You can also check the Teradici PCoIP Community Forum for troubleshooting

information about this product.

~/Library/Logs/Teradici/PCoIPClient

Troubleshooting Your PCoIP Software Client
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Session Log IDs

The PCoIP Software Client creates a unique session ID when a new session is established, and

distributes that ID to all components in the system. When PCoIP components generate log

messages, they are prefixed by this unique session ID, allowing administrators and support to

easily group events by session across multiple components:

For example:

Log messages that do not pertain to a specific session will show a string of zeroes in place of the

session log ID number.

yyyy-mm-ddThh:mm:ss.ffffffZ xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx > …

2015-11-06T08:01:18.688879Z 4208fb66-e22a-11d1-a7d7-00a0c982c00d > …

Session Log IDs
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Setting Log Levels

You can set log levels to determine the level of details provided in the log. Log levels range from 0

to 3, where 0 provides the least information and 3 provides the most information.

To set log levels:

•  where  is lowercase L and  is

desired the log level (1, 2, or 3).

open /Applications/PCoIPClient.app --args -l x l x

Setting Log Levels
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Locating PCoIP Software Client for macOS Log
Files

On a Mac computer, PCoIP Software Client log files are located within the user’s Home Library

folder, which is hidden by default. The recommended way to access Home Library files is to use

the macOS Console.

You can also display log files in a macOS terminal window.

To display log files using the macOS Console:

1. To open the Console, go to the Applications > Utilities folder, and then double-click Console.

2. In the FILES section of the Log List pane on the left, navigate to the following folder: 

3. Select the desired log file to view its contents in the main pane.

4. To copy the contents:

• Click anywhere in the log contents, and then select Edit > Select All.

• Select Edit > Copy.

• Paste the contents into an email or text file.

To display log files in a macOS terminal window:

1. To open a terminal window, go to the Applications > Utilities folder, and then double-click

Terminal.

2. Navigate to the PCoIP Software Client log folder by typing the following command at the

command line prompt:

3. Type  to display the list of log files.

4. To view the contents of a log file, use any macOS command-line editor to open it.

5. To open a terminal window, go to the Applications > Utilities folder, and then double-click 

Terminal.

~/

Library/Logs/Teradici/PCoIPClient

cd ~/Library/Logs/Teradici/PCoIPClient

ls

Locating PCoIP Software Client for macOS Log Files
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6. Navigate to the PCoIP Software Client log folder by typing the following command at the

command line prompt:

7. Type  to display the list of log files.

8. To view the contents of a log file, use any macOS command-line editor to open it.

cd ~/Library/Logs/Teradici/PCoIPClient

ls

Locating PCoIP Software Client for macOS Log Files
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Reconnecting a PCoIP Session

If a network interruption is detected, the PCoIP session enters a reconnecting phase. In this phase

the client will show you the network reconnecting dialog which indicates that there is a network

issue and that the client is trying to reconnect and re-establish the PCoIP session. You can click 

disconnect to cancel the attempted reconnect and disconnect the session completely. If the

reconnection is successful, the notification dialog will disappear and the session will be restored, if

not, the session will be disconnected completely.

Reconnecting a PCoIP Session
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